VS:GetPref

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetPref returns the on-off status of the specified preference item.

A table of preference dialog items and their corresponding IDs may be found in the VectorScript Appendix.

FUNCTION GetPref(
prefIndex :INTEGER) : BOOLEAN;
def vs.GetPref(prefIndex):
    return BOOLEAN

Parameters

prefIndex INTEGER Preference item constant.

Example

VectorScript

SelHandleStatus:=GetPref(17);

Example for a shortcut to toggle preference true/false:

SetPref(49,not GetPref(49));

Python

SelHandleStatus = vs.GetPref(17)

Version

Availability: from MiniCAD6.0

See Also

VS:SetPref

[[VS:SetPref]]