VS:GetPolylineArcMaxRadius

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Return a maximum radius of the specified vertex of type arc or radius of a polyline.

FUNCTION GetPolylineArcMaxRadius(
hPoly :HANDLE;
vertexNum :INTEGER) : REAL;
def vs.GetPolylineArcMaxRadius(hPoly, vertexNum):
    return REAL

Parameters

hPoly HANDLE Handle of the poliline
vertexNum INTEGER Index of vertex to be queried.

Return Value

If the vertex type is not arc or radius it returns -1.

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetPolylineVertex | VS:SetPolylineVertex

VS Functions:

[[VS:GetPolylineVertex]]

| [[VS:SetPolylineVertex]]