VS:GetPluginChoiceIndex

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns true with outIndex as specified by inPluginNameand inParameterName. Each of the input names are universal names.

FUNCTION GetPluginChoiceIndex(
inPluginName :STRING;
inParameterName :STRING;
inChoiceName :STRING;
VAR outIndex :INTEGER) : BOOLEAN;
def vs.GetPluginChoiceIndex(inPluginName, inParameterName, inChoiceName):
    return (BOOLEAN, outIndex)

Parameters

inPluginName STRING The universal name of the plug-in.
inParameterName STRING The universal name of the parameter.
inChoiceName STRING The universal name of the choice.
outIndex INTEGER The index of the requested choice. ( range is 1 to n)

Return Value

Returns true if the function succeeded.

Version

Availability: from VectorWorks10.0