VS:GetPenFore

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetPenFore returns the pen foreground color components of the referenced object. RGB values are in the range of 0~65535.

PROCEDURE GetPenFore(
h :HANDLE;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT);
def vs.GetPenFore(h):
    return (red, green, blue)

Parameters

h HANDLE Handle to object.
red LONGINT Returns RGB color component value.
green LONGINT Returns RGB color component value.
blue LONGINT Returns RGB color component value.

Example

VectorScript

GetPenFore(handleToObject,redValue,greenValue,blueValue);

Python

redValue,greenValue,blueValue = vs.GetPenFore(handleToObject)

Version

Availability: from MiniCAD6.0

See Also

VS Functions:

VS:ColorIndexToRGB | VS:RGBToColorIndex

VS Functions:

[[VS:ColorIndexToRGB]]

| [[VS:RGBToColorIndex]]