VS:GetOriginInDocUnits

From Vectorworks Developer
Revision as of 17:43, 16 September 2015 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetOriginInDocUnits returns the current origin location relative to the center of the page in current units. It fixes the problem existing for GetOrigin (see remarks). The behavior is the same while used during objects reset and in commands.

PROCEDURE GetOriginInDocUnits(
VAR x :REAL;
VAR y :REAL);
def vs.GetOriginInDocUnits():
    return (x, y)

Parameters

x REAL Returns X coordinate of origin.
y REAL Returns Y coordinate of origin.

Example

PROCEDURE Example;
VAR
originPt : VECTOR;
BEGIN
GetOriginInDocUnits(originPt.x, originPt.y);
Message(originPt);
END;
RUN(Example);

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:GetOrigin

VS Functions: [[VS:GetOrigin]]