VS:GetOpacityByClass

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns whether the object is using the class opacity.

PROCEDURE GetOpacityByClass(
h :HANDLE;
VAR isByClass :BOOLEAN);
def vs.GetOpacityByClass(h):
    return isByClass

Parameters

h HANDLE The object which opacity will be get.
isByClass BOOLEAN Output parameter. Returns TRUE if this object's opacity is determined by its class.

Remarks

If you set opacity to an object inside parametric the actual opacity will be combined with the opacity of the parametric object itself. For example a rectangle with 50% opacity inside a parametric with 50% opacity will actually be rendered with 25% opacity. This behavior is the same for symbols too.

Version

Availability: from VectorWorks13.0

See Also

VS:GetOpacity | VS:SetOpacity | VS:GetOpacityByClass | VS:SetOpacityByClass

[[VS:GetOpacity]] | [[VS:SetOpacity]] | [[VS:GetOpacityByClass]] | [[VS:SetOpacityByClass]]