VS:GetOpacity

From Vectorworks Developer
Revision as of 18:15, 30 June 2009 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the opacity of and object. Opacity is obtained as percentage value in range [0-100].

PROCEDURE GetOpacity(
h :HANDLE;
VAR opacity :INTEGER);
def vs.GetOpacity(h):
    return opacity

Parameters

h HANDLE The object which opacity will be get.
opacity INTEGER Output parameter. Return the object's opacity as percentage value in range [0-100].

Remarks

If you set opacity to an object inside parametric the actual opacity will be combined with the opacity of the parametric object itself. For example a rectangle with 50% opacity inside a parametric with 50% opacity will actually be rendered with 25% opacity. This behavior is the same for symbols too.

Version

Availability: from VectorWorks13.0

See Also

VS:GetOpacity | VS:SetOpacity | VS:GetOpacityByClass | VS:SetOpacityByClass

[[VS:GetOpacity]] | [[VS:SetOpacity]] | [[VS:GetOpacityByClass]] | [[VS:SetOpacityByClass]]