VS:GetObjectWallOffset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(fix typo)
(successful, not successfull. I looked this one up)
 
Line 8: Line 8:
Gets an object's offset value in it's break record.
Gets an object's offset value in it's break record.


The object (objH) must be contained in wall (wallH) to succeed.</desc>
The object (objH) must be contained in wall (wallH) to succeed.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 44: Line 44:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
True or False upon successfull setting of the flag.
True or False upon successful setting of the flag.


False can occur for the following conditions:
False can occur for the following conditions:

Latest revision as of 15:07, 21 September 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets an object's offset value in it's break record.

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION GetObjectWallOffset(
objH :HANDLE;
wallH :HANDLE;
VAR offset :REAL) : BOOLEAN;
def vs.GetObjectWallOffset(objH, wallH):
    return (BOOLEAN, offset)

Parameters

objH HANDLE
wallH HANDLE
offset REAL

Return Value

True or False upon successful setting of the flag.

False can occur for the following conditions:

  • objH is null.
  • wallH is null.
  • objH is not contained in wallH.

Version

Availability: from Vectorworks 2015