VS:GetObjectWallHeight

From Vectorworks Developer
Revision as of 14:35, 18 September 2014 by Root (talk | contribs) (1 revision: vw2015)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets an object's height value in it's break record.


The oject (objH) must be contained in wall (wallH) to succeed.

FUNCTION GetObjectWallHeight(
objH :HANDLE;
wallH :HANDLE;
VAR height :REAL) : BOOLEAN;
def vs.GetObjectWallHeight(objH, wallH):
    return (BOOLEAN, height)

Parameters

objH HANDLE
wallH HANDLE
height REAL

Return Value

True or False upon successfull setting of the flag.


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Version

Availability: from Vectorworks 2015