VS:GetObjectVariableString

From Vectorworks Developer
Revision as of 17:03, 28 April 2008 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the value of a VectorWorks object property. Used with properties returning a STRING value.

For specific object selector index values, see the Appendix.

FUNCTION GetObjectVariableString(
h :HANDLE;
index :INTEGER) : STRING;
def vs.GetObjectVariableString(h, index):
    return STRING

Parameters

h HANDLE Handle to object.
index INTEGER Object property index.

Return Value

Returns the value of the property as a STRING value.

Example

VectorScript

dimstdName:= GetObjectVariableString(h,27);

Python

dimstdName = vs.GetObjectVariableString(h,27)

Version

Availability: from VectorWorks9.0