VS:GetObjectVariableReal

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the value of a VectorWorks object property. Used with properties returning a REAL value. Always returns values in mm, regardless of document units.

For specific object selector index values, see the Appendix.

FUNCTION GetObjectVariableReal(
h :HANDLE;
index :INTEGER) : REAL;
def vs.GetObjectVariableReal(h, index):
    return REAL

Parameters

h HANDLE Handle to object.
index INTEGER Object property index.

Return Value

Returns the value of the property as a REAL value.

Example

VectorScript

dim_offset:= GetObjectVariableReal(h,4);

Python

dim_offset = vs.GetObjectVariableReal(h,4)

Version

Availability: from VectorWorks9.0