VS:GetObjectVariablePoint: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(fix error in definition)
Line 43: Line 43:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>([[User:Orso.b.schmid|Orso]], 2015.03.01):
The definition is not correct: expected VAR is not one singular REAL, but three (x, y, z):
FUNCTION GetObjectVariablePoint(
  h          :HANDLE;
  index      :INTEGER;
  VAR outPx, outPy, outPz  :REAL) : BOOLEAN;
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 17:31, 1 March 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the value of a Vectorworks object property. Used with properties returning a 2D or 3D point value.


For specific object selector index values, see the Appendix.

FUNCTION GetObjectVariablePoint(
h :HANDLE;
index :INTEGER;
VAR outP :REAL) : BOOLEAN;
def vs.GetObjectVariablePoint(h, index):
    return (BOOLEAN, outP)

Parameters

h HANDLE Handle to object.
index INTEGER Object property index.
outP REAL Return the object variable data point.

Remarks

(Orso, 2015.03.01):

The definition is not correct: expected VAR is not one singular REAL, but three (x, y, z):

FUNCTION GetObjectVariablePoint(
  h          :HANDLE;
  index      :INTEGER;
  VAR outPx, outPy, outPz   :REAL) : BOOLEAN;

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetObjectVariablePoint | VS:GetObjectVariableBoolean | VS:SetObjectVariableBoolean | VS:GetObjectVariableHandle | VS:SetObjectVariableHandle | VS:GetObjectVariableInt | VS:SetObjectVariableInt | VS:GetObjectVariableLongInt | VS:SetObjectVariableLongInt | VS:GetObjectVariableReal | VS:SetObjectVariableReal | VS:GetObjectVariableString | VS:SetObjectVariableString

VS Functions:

[[VS:SetObjectVariablePoint]] | [[VS:GetObjectVariableBoolean]] | [[VS:SetObjectVariableBoolean]] | [[VS:GetObjectVariableHandle]] | [[VS:SetObjectVariableHandle]] | [[VS:GetObjectVariableInt]] | [[VS:SetObjectVariableInt]] | [[VS:GetObjectVariableLongInt]] | [[VS:SetObjectVariableLongInt]] | [[VS:GetObjectVariableReal]] | [[VS:SetObjectVariableReal]] | [[VS:GetObjectVariableString]]

| [[VS:SetObjectVariableString]]