VS:GetObjectVariablePoint: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(fix error in definition)
No edit summary
 
Line 13: Line 13:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetObjectVariablePoint(h:HANDLE; index:INTEGER; VAR outP:REAL) : BOOLEAN;
FUNCTION GetObjectVariablePoint(h:HANDLE; index:INTEGER; VAR outPx, outPy, outPz :REAL) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 43: Line 43:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>([[User:Orso.b.schmid|Orso]], 2015.03.01):
<remark>
The definition is not correct: expected VAR is not one singular REAL, but three (x, y, z):
In python scripting, the point 'outP' will be returned as tuple (x,y,z)
FUNCTION GetObjectVariablePoint(
  h          :HANDLE;
  index      :INTEGER;
  VAR outPx, outPy, outPz  :REAL) : BOOLEAN;


</remark>
</remark>

Latest revision as of 13:27, 3 March 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the value of a Vectorworks object property. Used with properties returning a 2D or 3D point value.


For specific object selector index values, see the Appendix.

FUNCTION GetObjectVariablePoint(
h :HANDLE;
index :INTEGER;
VAR outPx, outPy, outPz :REAL) : BOOLEAN;
def vs.GetObjectVariablePoint(h, index):
    return (BOOLEAN, outP)

Parameters

h HANDLE Handle to object.
index INTEGER Object property index.
outP REAL Return the object variable data point.

Remarks

In python scripting, the point 'outP' will be returned as tuple (x,y,z)

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetObjectVariablePoint | VS:GetObjectVariableBoolean | VS:SetObjectVariableBoolean | VS:GetObjectVariableHandle | VS:SetObjectVariableHandle | VS:GetObjectVariableInt | VS:SetObjectVariableInt | VS:GetObjectVariableLongInt | VS:SetObjectVariableLongInt | VS:GetObjectVariableReal | VS:SetObjectVariableReal | VS:GetObjectVariableString | VS:SetObjectVariableString

VS Functions:

[[VS:SetObjectVariablePoint]] | [[VS:GetObjectVariableBoolean]] | [[VS:SetObjectVariableBoolean]] | [[VS:GetObjectVariableHandle]] | [[VS:SetObjectVariableHandle]] | [[VS:GetObjectVariableInt]] | [[VS:SetObjectVariableInt]] | [[VS:GetObjectVariableLongInt]] | [[VS:SetObjectVariableLongInt]] | [[VS:GetObjectVariableReal]] | [[VS:SetObjectVariableReal]] | [[VS:GetObjectVariableString]]

| [[VS:SetObjectVariableString]]