VS:GetObjectVariableBoolean

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the ON-OFF status of a VectorWorks object property.

For specific object selector index values, see the Appendix.

FUNCTION GetObjectVariableBoolean(
h :HANDLE;
index :INTEGER) : BOOLEAN;
def vs.GetObjectVariableBoolean(h, index):
    return BOOLEAN

Parameters

h HANDLE Handle to object.
index INTEGER Object property index.

Return Value

Returns a BOOLEAN value indicating the ON-OFF status of the property.

Remarks

From Julian: Appears to be unreliable for walls because it returns a different result depending on the view. Walls always report false for 2D, but only report true for 3D if in a 3D view.

Example

VectorScript

castShadow:= GetObjectVariableBoolean(h,53);

Python

castShadow = vs.GetObjectVariableBoolean(h,53)

Version

Availability: from VectorWorks9.0