VS:GetObjectTags

From Vectorworks Developer
Revision as of 21:35, 11 April 2024 by PStanford (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Lets the user query the list of Tags set on an object such as a Class,Layer or Resource.

FUNCTION GetObjectTags(
objHandle :HANDLE;
VAR outArrTags :ARRAY) : BOOLEAN;
def vs.GetObjectTags(objHandle):
    return (BOOLEAN, outArrTags)

Parameters

objHandle HANDLE The handle to the object to query Tags from.
outArrTags ARRAY The output array of Tags queried from the object.
For Python, the passed data must be a tuple. A list will not work.

Version

Availability: from Vectorworks 2019