VS:GetObjectTags: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 32: Line 32:
The output array of Tags queried from the object.
The output array of Tags queried from the object.
</line>
</line>
<line>
</lineList>
For Python, the passed data must be a tuple.  A list will not work.
For Python, the passed data must be a tuple.  A list will not work.
</line>
</lineList>
</params>
</params>



Revision as of 21:37, 11 April 2024

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Lets the user query the list of Tags set on an object such as a Class,Layer or Resource.

FUNCTION GetObjectTags(
objHandle :HANDLE;
VAR outArrTags :ARRAY) : BOOLEAN;
def vs.GetObjectTags(objHandle):
    return (BOOLEAN, outArrTags)

Parameters

objHandle HANDLE The handle to the object to query Tags from.
outArrTags ARRAY The output array of Tags queried from the object.

For Python, the passed data must be a tuple. A list will not work.

Version

Availability: from Vectorworks 2019