VS:GetObjectTags: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
(One intermediate revision by the same user not shown)
Line 33: Line 33:
</line>
</line>
</lineList>
</lineList>
For Python, the passed data must be a tuple.  A list will not work.
</params>
</params>



Revision as of 21:37, 11 April 2024

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Lets the user query the list of Tags set on an object such as a Class,Layer or Resource.

FUNCTION GetObjectTags(
objHandle :HANDLE;
VAR outArrTags :ARRAY) : BOOLEAN;
def vs.GetObjectTags(objHandle):
    return (BOOLEAN, outArrTags)

Parameters

objHandle HANDLE The handle to the object to query Tags from.
outArrTags ARRAY The output array of Tags queried from the object.

For Python, the passed data must be a tuple. A list will not work.

Version

Availability: from Vectorworks 2019