VS:GetObjectHiddenLine: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (1 revision)
 
(One intermediate revision by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Create lines representing the hidden line geometry of the specified object.
Create lines representing the hidden line geometry of the specified object.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE GetObjectHiddenLine(hGeometry3D: HANDLE; cuttingHeight: REAL; bottomOfCutPlane: BOOLEAN) : HANDLE;
FUNCTION GetObjectHiddenLine(hGeometry3D:HANDLE; cuttingHeight:REAL; bottomOfCutPlane:BOOLEAN) : HANDLE;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 25: Line 24:
hGeometry3D
hGeometry3D
HANDLE
HANDLE
to be specified
 
</line>
</line>
<line>
<line>
cuttingHeight
cuttingHeight
REAL
REAL
to be specified
 
</line>
</line>
<line>
<line>
bottomOfCutPlane
bottomOfCutPlane
BOOLEAN
BOOLEAN
to be specified
 
</line>
</line>
</lineList>
</lineList>
Line 41: Line 40:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark></remark>
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample></sample>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso></seeAlso>
 
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from Vectorworks 2013
Availability: from Vectorworks 2014


</version>
</version>
Line 61: Line 56:
</vwDoc>
</vwDoc>


[[Category:VS Function Reference|EnableLBHierDisplay]]
[[Category:VS Function Reference|GetObjectHiddenLine]]
[[Category:VS Function Reference:Dialogs - Modern - Browser|EnableLBHierDisplay]]
[[Category:VS Function Reference:Graphic Calculation|GetObjectHiddenLine]]

Latest revision as of 17:36, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Create lines representing the hidden line geometry of the specified object.

FUNCTION GetObjectHiddenLine(
hGeometry3D :HANDLE;
cuttingHeight :REAL;
bottomOfCutPlane :BOOLEAN) : HANDLE;
def vs.GetObjectHiddenLine(hGeometry3D, cuttingHeight, bottomOfCutPlane):
    return HANDLE

Parameters

hGeometry3D HANDLE
cuttingHeight REAL
bottomOfCutPlane BOOLEAN

Version

Availability: from Vectorworks 2014