VS:GetObjWallInsertMode/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

壁に挿入したオブジェクトの、壁への挿入位置を返します。

1 - 壁の中心
2 - 壁の左面
3 - 壁の右面


オブジェクトが壁に挿入されている必要があります。

FUNCTION GetObjWallInsertMode(
objH :HANDLE;
wallH :HANDLE;
VAR insertMode :INTEGER) : Boolean;
def vs.GetObjWallInsertMode(objH, wallH, insertMode):
    return (Boolean, insertMode)

Parameters

objH HANDLE
wallH HANDLE
insertMode INTEGER

Return Value

壁への挿入位置を正常に取得できた場合にTrueを返します。

次のような場合にFalseを返します:
オブジェクトのハンドルが null
壁のハンドルが null
オブジェクトが壁に挿入されていない

Version

利用可能バージョン: Vectorworks 2017