VS:GetObjWallInsertMode

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the insertion mode for an object in a wall.


0 - Wall - Centerline
1 - Wall - Left Edge
2 - Wall - Right Edge
3 - Core Component - Centerline
4 - Core Component - Left Edge
5 - Core Component - Right Edge

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION GetObjWallInsertMode(
objH :HANDLE;
wallH :HANDLE;
VAR insertMode :INTEGER) : Boolean;
def vs.GetObjWallInsertMode(objH, wallH, insertMode):
    return (Boolean, insertMode)

Parameters

objH HANDLE
wallH HANDLE
insertMode INTEGER

Return Value

True or False upon successful retrieving of the insertion mode.


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Remarks

Ptr 2022.07.01:

In Python the third parameter (insertMode) doesn't do anything, but it needs to be entered to avoid an error message.

Version

Availability: from Vectorworks 2017