VS:GetObjWallInsertMode

From Vectorworks Developer
Revision as of 12:32, 14 April 2020 by CBM-c- (talk | contribs) (fails on round walls)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the insertion mode for an object in a wall.

0 = Center
1 = Left Edge
2 = Right Edge

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION GetObjWallInsertMode(
objH :HANDLE;
wallH :HANDLE;
VAR insertMode :INTEGER) : Boolean;
def vs.GetObjWallInsertMode(objH, wallH, insertMode):
    return (Boolean, insertMode)

Parameters

objH HANDLE
wallH HANDLE
insertMode INTEGER

Return Value

True or False upon successful retrieving of the insertion mode.

False can occur for the following conditions:

  • objH is null.
  • wallH is null.

objH is not contained in wallH.

Remarks

(Orso, 2020.04.14)

Fails on Round Walls (bug filed, tested on VW 2019, 2020).

Version

Availability: from Vectorworks 2017