VS:GetObjWallInsertMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(4 intermediate revisions by 2 users not shown)
Line 8: Line 8:
Returns the insertion mode for an object in a wall.<BR>
Returns the insertion mode for an object in a wall.<BR>
<BR>
<BR>
1 - Center<BR>
0 - Wall - Centerline<BR>
2 - Leaf Edge<BR>
1 - Wall - Left Edge<BR>
3 - Right Edge<BR>
2 - Wall - Right Edge<BR>
<BR>
3 - Core Component - Centerline<BR>
4 - Core Component - Left Edge<BR>
5 - Core Component - Right Edge<BR>
<BR>
<BR>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>
Line 54: Line 56:
objH is null.<BR>
objH is null.<BR>
wallH is null.<BR>
wallH is null.<BR>
objH is not contained in wallH.</return>
objH is not contained in wallH.<BR>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
[[User:Ptr|Ptr]] 2022.07.01:
In Python the third parameter (insertMode) doesn't do anything, but it needs to be entered to avoid an error message.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 13:42, 1 July 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the insertion mode for an object in a wall.


0 - Wall - Centerline
1 - Wall - Left Edge
2 - Wall - Right Edge
3 - Core Component - Centerline
4 - Core Component - Left Edge
5 - Core Component - Right Edge

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION GetObjWallInsertMode(
objH :HANDLE;
wallH :HANDLE;
VAR insertMode :INTEGER) : Boolean;
def vs.GetObjWallInsertMode(objH, wallH, insertMode):
    return (Boolean, insertMode)

Parameters

objH HANDLE
wallH HANDLE
insertMode INTEGER

Return Value

True or False upon successful retrieving of the insertion mode.


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Remarks

Ptr 2022.07.01:

In Python the third parameter (insertMode) doesn't do anything, but it needs to be entered to avoid an error message.

Version

Availability: from Vectorworks 2017