VS:GetObjWallInsertMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(fails on round walls)
No edit summary
 
(6 intermediate revisions by the same user not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns the insertion mode for an object in a wall.
Returns the insertion mode for an object in a wall.<BR>
: 0 = Center
<BR>
: 1 = Left Edge
0 - Wall - Centerline<BR>
: 2 = Right Edge
1 - Wall - Left Edge<BR>
 
2 - Wall - Right Edge<BR>
3 - Core Component - Centerline<BR>
4 - Core Component - Left Edge<BR>
5 - Core Component - Right Edge<BR>
<BR>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>


Line 47: Line 51:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
True or False upon successful retrieving of the insertion mode.
True or False upon successful retrieving of the insertion mode.<BR>
 
<BR>
False can occur for the following conditions:
False can occur for the following conditions:<BR>
* objH is null.
objH is null.<BR>
* wallH is null.
wallH is null.<BR>
objH is not contained in wallH.</return>
objH is not contained in wallH.<BR>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2020.04.14)
[[User:Ptr|Ptr]] 2022.07.01:
Fails on Round Walls (bug filed, tested on VW 2019, 2020).
In Python the third parameter (insertMode) doesn't do anything, but it needs to be entered to avoid an error message.
</remark>
</remark>



Latest revision as of 13:42, 1 July 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the insertion mode for an object in a wall.


0 - Wall - Centerline
1 - Wall - Left Edge
2 - Wall - Right Edge
3 - Core Component - Centerline
4 - Core Component - Left Edge
5 - Core Component - Right Edge

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION GetObjWallInsertMode(
objH :HANDLE;
wallH :HANDLE;
VAR insertMode :INTEGER) : Boolean;
def vs.GetObjWallInsertMode(objH, wallH, insertMode):
    return (Boolean, insertMode)

Parameters

objH HANDLE
wallH HANDLE
insertMode INTEGER

Return Value

True or False upon successful retrieving of the insertion mode.


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Remarks

Ptr 2022.07.01:

In Python the third parameter (insertMode) doesn't do anything, but it needs to be entered to avoid an error message.

Version

Availability: from Vectorworks 2017