VS:GetObjWallInsertMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (wikify)
m (1 revision)
(One intermediate revision by the same user not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns the insertion mode for an object in a wall.
Returns the insertion mode for an object in a wall.<BR>
: 0 = Center
<BR>
: 1 = Left Edge
1 - Center<BR>
: 2 = Right Edge
2 - Leaf Edge<BR>
 
3 - Right Edge<BR>
<BR>
<BR>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>
The object (objH) must be contained in wall (wallH)  to succeed.</desc>


Line 47: Line 49:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
True or False upon successful retrieving of the insertion mode.
True or False upon successful retrieving of the insertion mode.<BR>
 
<BR>
False can occur for the following conditions:
False can occur for the following conditions:<BR>
* objH is null
objH is null.<BR>
* wallH is null
wallH is null.<BR>
* objH is not contained in wallH.</return>
objH is not contained in wallH.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark></remark>
([[User:Orso.b.schmid|Orso]], 2020.04.14)
Fails on Round Walls (bug filed, tested on VW 2019, 2020).
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 18:51, 7 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the insertion mode for an object in a wall.


1 - Center
2 - Leaf Edge
3 - Right Edge


The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION GetObjWallInsertMode(
objH :HANDLE;
wallH :HANDLE;
VAR insertMode :INTEGER) : Boolean;
def vs.GetObjWallInsertMode(objH, wallH, insertMode):
    return (Boolean, insertMode)

Parameters

objH HANDLE
wallH HANDLE
insertMode INTEGER

Return Value

True or False upon successful retrieving of the insertion mode.


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Version

Availability: from Vectorworks 2017