VS:GetObjWallInsertMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
m (wikify)
(2 intermediate revisions by the same user not shown)
Line 7: Line 7:
<desc>
<desc>
Returns the insertion mode for an object in a wall.
Returns the insertion mode for an object in a wall.
: 0 = Center
: 0 = Center
: 1 = Leaf Edge
: 1 = Left Edge
: 2 = Right Edge
: 2 = Right Edge


Line 48: Line 47:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
True or False upon successful retrieving of the insertion mode.<BR>
True or False upon successful retrieving of the insertion mode.
<BR>
 
False can occur for the following conditions:<BR>
False can occur for the following conditions:
objH is null.<BR>
* objH is null
wallH is null.<BR>
* wallH is null
objH is not contained in wallH.</return>
* objH is not contained in wallH.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2020.04.14)
Fails on Round Walls (bug filed, tested on VW 2019, 2020).
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 12:33, 14 April 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the insertion mode for an object in a wall.

0 = Center
1 = Left Edge
2 = Right Edge

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION GetObjWallInsertMode(
objH :HANDLE;
wallH :HANDLE;
VAR insertMode :INTEGER) : Boolean;
def vs.GetObjWallInsertMode(objH, wallH, insertMode):
    return (Boolean, insertMode)

Parameters

objH HANDLE
wallH HANDLE
insertMode INTEGER

Return Value

True or False upon successful retrieving of the insertion mode.

False can occur for the following conditions:

  • objH is null
  • wallH is null
  • objH is not contained in wallH.

Remarks

(Orso, 2020.04.14)

Fails on Round Walls (bug filed, tested on VW 2019, 2020).

Version

Availability: from Vectorworks 2017