VS:GetObjWallInsertMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
m (fix autocorrect)
Line 7: Line 7:
<desc>
<desc>
Returns the insertion mode for an object in a wall.
Returns the insertion mode for an object in a wall.
: 0 = Center
: 0 = Center
: 1 = Leaf Edge
: 1 = Left Edge
: 2 = Right Edge
: 2 = Right Edge



Revision as of 09:06, 29 March 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the insertion mode for an object in a wall.

0 = Center
1 = Left Edge
2 = Right Edge

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION GetObjWallInsertMode(
objH :HANDLE;
wallH :HANDLE;
VAR insertMode :INTEGER) : Boolean;
def vs.GetObjWallInsertMode(objH, wallH, insertMode):
    return (Boolean, insertMode)

Parameters

objH HANDLE
wallH HANDLE
insertMode INTEGER

Return Value

True or False upon successful retrieving of the insertion mode.


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Version

Availability: from Vectorworks 2017