VS:GetObjWallBreakMode/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

壁に挿入したオブジェクトの、壁の処理モードを返します。

1 - 線を消す(小口あり)
2 - 線を消す(小口なし)
3 - 線を見せる(一方のみ)
4 - 線を見せる(両方)

オブジェクトが壁に挿入されている必要があります。

FUNCTION GetObjWallBreakMode(
objH :HANDLE;
wallH :HANDLE;
VAR breakMode :INTEGER) : Boolean;
def vs.GetObjWallBreakMode(objH, wallH, breakMode):
    return (Boolean, breakMode)

Parameters

objH HANDLE
wallH HANDLE
breakMode INTEGER

Return Value

壁の処理を正常に取得できた場合にTrueを返します。

次のような場合にFalseを返します:
オブジェクトのハンドルが null
壁のハンドルが null
オブジェクトが壁に挿入されていない

Version

利用可能バージョン: Vectorworks 2017