VS:GetObjWallBreakMode

From Vectorworks Developer
Revision as of 18:51, 7 December 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the break mode for an object in a wall.


1 - Full Break with Caps
2 - Full Break no Caps
3 - Half Break
4 - No Break

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION GetObjWallBreakMode(
objH :HANDLE;
wallH :HANDLE;
VAR breakMode :INTEGER) : Boolean;
def vs.GetObjWallBreakMode(objH, wallH, breakMode):
    return (Boolean, breakMode)

Parameters

objH HANDLE
wallH HANDLE
breakMode INTEGER

Return Value

True or False upon successful retrieving of the break mode.


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Version

Availability: from Vectorworks 2017