VS:GetObjWallBreakMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 19:43, 16 September 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the break mode for an object in a wall.


1 - Full Break with Caps
2 - Full Break no Caps
3 - Half Break
4 - No Break

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION GetObjWallBreakMode(
objH :HANDLE;
wallH :HANDLE;
VAR breakMode :INTEGER) : Boolean;
def vs.GetObjWallBreakMode(objH, wallH, breakMode):
    return (Boolean, breakMode)

Parameters

objH HANDLE
wallH HANDLE
breakMode INTEGER

Return Value

True or False upon successful retrieving of the break mode.


False can occur for the following conditions:
objH is null.
wallH is null.
objH is not contained in wallH.

Version

Availability: from Vectorworks 2017