VS:GetObjStoryBoundsAt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(Shorten OBJECT, reserved word)
 
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetObjStoryBoundsAt(object:HANDLE; index:INTEGER) : INTEGER;
FUNCTION GetObjStoryBoundsAt(obj:HANDLE; index:INTEGER) : INTEGER;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetObjStoryBoundsAt(object, index):
def vs.GetObjStoryBoundsAt(obj, index):
     return INTEGER
     return INTEGER
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object.
The object.

Latest revision as of 19:59, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Return the story bound ID of the specified story bound index. The index is between 1 and the result of GetObjStoryBoundsCnt.

FUNCTION GetObjStoryBoundsAt(
obj :HANDLE;
index :INTEGER) : INTEGER;
def vs.GetObjStoryBoundsAt(obj, index):
    return INTEGER

Parameters

obj HANDLE The object.
index INTEGER Index of the story bound which ID will be returned. This index should be between 1 and the result of GetObjStoryBoundsCnt.

Return Value

Return the story bound ID.

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:HasObjStoryBounds | VS:HasObjStoryBound | VS:GetObjStoryBound | VS:SetObjectStoryBound | VS:DelObjStoryBounds | VS:DelObjStoryBound | VS:GetObjStoryBoundsCnt | VS:GetObjStoryBoundsAt

VS Functions:

[[VS:HasObjStoryBounds]] | [[VS:HasObjStoryBound]] | [[VS:GetObjStoryBound]] | [[VS:SetObjectStoryBound]] | [[VS:DelObjStoryBounds]] | [[VS:DelObjStoryBound]] | [[VS:GetObjStoryBoundsCnt]]

| [[VS:GetObjStoryBoundsAt]]