VS:GetObjStoryBound

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the data of the specified story bound of this object.

FUNCTION GetObjStoryBound(
object :HANDLE;
boundID :INTEGER;
VAR boundType :INTEGER;
VAR boundStory :INTEGER;
VAR layerLevelType :STRING;
VAR offset :REAL) : BOOLEAN;
def vs.GetObjStoryBound(object, boundID):
    return (BOOLEAN, boundType, boundStory, layerLevelType, offset)

Parameters

object HANDLE The object.
boundID INTEGER The identifier of the story bound.
boundType INTEGER Bounding type: 0 - DefaultWallHeight; 1 - LayerZ; 2 - Story
boundStory INTEGER The story identified by 'boundType' = (2 - Story). If 'boundStory' = 0 then it is this story (the object's story); If 'boundStory' = 1 then it is the story above; If 'boundStory' = 2 then it is the story below.
layerLevelType STRING The layer type which defines this bound
offset REAL The offset distance from the specified bound story

Return Value

Return TRUE if the operation is successful.

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:HasObjStoryBounds | VS:HasObjStoryBound | VS:GetObjStoryBound | VS:SetObjectStoryBound | VS:DelObjStoryBounds | VS:DelObjStoryBound | VS:GetObjStoryBoundsCnt | VS:GetObjStoryBoundsAt

VS Functions:

[[VS:HasObjStoryBounds]] | [[VS:HasObjStoryBound]] | [[VS:GetObjStoryBound]] | [[VS:SetObjectStoryBound]] | [[VS:DelObjStoryBounds]] | [[VS:DelObjStoryBound]] | [[VS:GetObjStoryBoundsCnt]]

| [[VS:GetObjStoryBoundsAt]]