VS:GetObjStoryBound

From Vectorworks Developer
Revision as of 19:58, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the data of the specified story bound of this object.

FUNCTION GetObjStoryBound(
obj :HANDLE;
boundID :INTEGER;
VAR boundType :INTEGER;
VAR boundStory :INTEGER;
VAR layerLevelType :STRING;
VAR offset :REAL) : BOOLEAN;
def vs.GetObjStoryBound(obj, boundID):
    return (BOOLEAN, boundType, boundStory, layerLevelType, offset)

Parameters

obj HANDLE The object.
boundID INTEGER The identifier of the story bound.
boundType INTEGER Bounding type: 0 - DefaultWallHeight; 1 - LayerZ; 2 - Story
boundStory INTEGER The story identified by 'boundType' = (2 - Story). If 'boundStory' = 0 then it is this story (the object's story); If 'boundStory' = 1 then it is the story above; If 'boundStory' = 2 then it is the story below.
layerLevelType STRING The layer type which defines this bound
offset REAL The offset distance from the specified bound story

Return Value

Return TRUE if the operation is successful.

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:HasObjStoryBounds | VS:HasObjStoryBound | VS:GetObjStoryBound | VS:SetObjectStoryBound | VS:DelObjStoryBounds | VS:DelObjStoryBound | VS:GetObjStoryBoundsCnt | VS:GetObjStoryBoundsAt

VS Functions:

[[VS:HasObjStoryBounds]] | [[VS:HasObjStoryBound]] | [[VS:GetObjStoryBound]] | [[VS:SetObjectStoryBound]] | [[VS:DelObjStoryBounds]] | [[VS:DelObjStoryBound]] | [[VS:GetObjStoryBoundsCnt]]

| [[VS:GetObjStoryBoundsAt]]