VS:GetObjExpandTexture

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetObjExpandTexture returns whether the referenced objects' textures have been "expanded". When a texture is expanded, different components of an object can have different textures.

FUNCTION GetObjExpandTexture(
obj :HANDLE) : BOOLEAN;
def vs.GetObjExpandTexture(obj):
    return BOOLEAN

Parameters

obj HANDLE Handle to object.

Remarks

This function returns true if the object's textures are expanded. For example, if the object is a wall and this function returns true then there are three distinct textures applied to the left, center, and right polygons.

Version

Availability: from VectorWorks8.0