VS:GetObjEndMarker

From Vectorworks Developer
Revision as of 19:58, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets all properties for an object's end marker. Return TRUE if operation was successful.

FUNCTION GetObjEndMarker(
obj :HANDLE;
VAR style :LONGINT;
VAR angle :INTEGER;
VAR size :REAL;
VAR width :REAL;
VAR thicknessBasis :INTEGER;
VAR thickness :REAL;
VAR visibility :BOOLEAN) : BOOLEAN;
def vs.GetObjEndMarker(obj):
    return (BOOLEAN, style, angle, size, width, thicknessBasis, thickness, visibility)

Parameters

obj HANDLE Handle to object.
style LONGINT The marker style. (see comments for details)
angle INTEGER The marker angle in degrees. (0 to 90)
size REAL The marker size in page inches.
width REAL The marker width in page inches.
thicknessBasis INTEGER The marker thickness basis. ( see comments for details)
thickness REAL The marker thickness.
visibility BOOLEAN The marker visibility.

Example

VectorScript

PROCEDURE Example;
VAR
h: HANDLE;
style: INTEGER;
angle: INTEGER;
size: REAL;
width: REAL;
thickBasis: INTEGER;
thickness: REAL;
visibility: BOOLEAN;

ok : BOOLEAN;

BEGIN
h := FSActLayer;
ok := GetObjEndMarker (h, style, angle, size, width, thickBasis, thickness, visibility);
Message (style, ' /  ', angle, '  /  ', size, '  /  ', width, ' /  ', thickBasis, ' /  ', thickness, ' /  ', visibility);
END;

RUN(Example);

Python

def Example()
	h = vs.FSActLayer()
	ok, style, angle, size, width, thickBasis, thickness, visibility = vs.GetObjEndMarker (h)
	vs.Message (style, ' /  ', angle, '  /  ', size, '  /  ', width, ' /  ', thickBasis, ' /  ', thickness, ' /  ', visibility)
Example()

Version

Availability: from VectorWorks13.0

See Also

VS Functions:

VS:GetObjBeginningMarker

VS Functions: [[VS:GetObjBeginningMarker]]