VS:GetObjBoundElevation: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetObjBoundElevation(object:HANDLE; boundID:INTEGER) : REAL;
FUNCTION GetObjBoundElevation(obj:HANDLE; boundID:INTEGER) : REAL;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetObjBoundElevation(object, boundID):
def vs.GetObjBoundElevation(obj, boundID):
     return REAL
     return REAL
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object.
The object.

Revision as of 19:57, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the elevation of the specified bound ID relative to the object's layer.

FUNCTION GetObjBoundElevation(
obj :HANDLE;
boundID :INTEGER) : REAL;
def vs.GetObjBoundElevation(obj, boundID):
    return REAL

Parameters

obj HANDLE The object.
boundID INTEGER The identifier of the story bound.

Return Value

Return the elevation of the specified bound ID relative to the object's layer.

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:HasObjStoryBounds | VS:HasObjStoryBound | VS:GetObjStoryBound | VS:SetObjectStoryBound | VS:DelObjStoryBounds | VS:DelObjStoryBound | VS:GetObjStoryBoundsCnt | VS:GetObjStoryBoundsAt

VS Functions:

[[VS:HasObjStoryBounds]] | [[VS:HasObjStoryBound]] | [[VS:GetObjStoryBound]] | [[VS:SetObjectStoryBound]] | [[VS:DelObjStoryBounds]] | [[VS:DelObjStoryBound]] | [[VS:GetObjStoryBoundsCnt]]

| [[VS:GetObjStoryBoundsAt]]