VS:GetObjBeginningMarker: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(Shorten OBJECT, reserved word)
 
(One intermediate revision by one other user not shown)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetObjBeginningMarker(object:HANDLE; VAR style:LONGINT; VAR angle:INTEGER; VAR size:REAL; VAR width:REAL; VAR thicknessBasis:INTEGER; VAR thickness:REAL; VAR visibility:BOOLEAN) : BOOLEAN;
FUNCTION GetObjBeginningMarker(obj:HANDLE; VAR style:LONGINT; VAR angle:INTEGER; VAR size:REAL; VAR width:REAL; VAR thicknessBasis:INTEGER; VAR thickness:REAL; VAR visibility:BOOLEAN) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetObjBeginningMarker(object):
def vs.GetObjBeginningMarker(obj):
     return (BOOLEAN, style, angle, size, width, thicknessBasis, thickness, visibility)
     return (BOOLEAN, style, angle, size, width, thicknessBasis, thickness, visibility)
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
Handle to object.
Handle to object.
Line 109: Line 109:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks13.0
Availability: from VectorWorks 13.0


</version>
</version>

Latest revision as of 19:57, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets all properties for an object's beginning marker. Return TRUE if operation was successful.

FUNCTION GetObjBeginningMarker(
obj :HANDLE;
VAR style :LONGINT;
VAR angle :INTEGER;
VAR size :REAL;
VAR width :REAL;
VAR thicknessBasis :INTEGER;
VAR thickness :REAL;
VAR visibility :BOOLEAN) : BOOLEAN;
def vs.GetObjBeginningMarker(obj):
    return (BOOLEAN, style, angle, size, width, thicknessBasis, thickness, visibility)

Parameters

obj HANDLE Handle to object.
style LONGINT The marker style. (see comments for details)
angle INTEGER The marker angle in degrees. (0 to 90)
size REAL The marker size in inches.
width REAL The marker width in inches.
thicknessBasis INTEGER The marker thickness basis. ( see comments for details)
thickness REAL The marker thickness.
visibility BOOLEAN The marker visibility.

Example

VectorScript

PROCEDURE Example;
VAR
h: HANDLE;
style: INTEGER;
angle: INTEGER;
size: REAL;
width: REAL;
thickBasis: INTEGER;
thickness: REAL;
visibility: BOOLEAN;

ok : BOOLEAN;

BEGIN
h := FSActLayer;
ok := GetObjBeginningMarker (h, style, angle, size, width, thickBasis, thickness, visibility);
Message (style, ' /  ', angle, '  /  ', size, '  /  ', width, ' /  ', thickBasis, ' /  ', thickness, ' /  ', visibility);
END;

RUN(Example);

Python

def Example():
	h = vs.FSActLayer()
	ok, style, angle, size, width, thickBasis, thickness, visibility = vs.GetObjBeginningMarker (h)
	vs.Message (style, ' /  ', angle, '  /  ', size, '  /  ', width, ' /  ', thickBasis, ' /  ', thickness, ' /  ', visibility)

Example()

Version

Availability: from VectorWorks 13.0

See Also

VS Functions:

VS:GetObjEndMarker

VS Functions: [[VS:GetObjEndMarker]]