VS:GetNurbsObjectDistanceFromPoint

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the distance from the input point to the input NURBS Object h.

FUNCTION GetNurbsObjectDistanceFromPoint(
h :HANDLE;
pointX,pointY :REAL;
VAR distance :REAL) : BOOLEAN;
def vs.GetNurbsObjectDistanceFromPoint(h, point):
    return (BOOLEAN, distance)

Parameters

h HANDLE Handle to a NURBS object.
point REAL point
distance REAL Distance between point and object.

Version

Availability: from VectorWorks10.0