VS:GetNumberOfComponents

From Vectorworks Developer
Revision as of 19:54, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the number of components in an object.

FUNCTION GetNumberOfComponents(
obj :HANDLE;
VAR numComponents :INTEGER) : BOOLEAN;
def vs.GetNumberOfComponents(obj):
    return (BOOLEAN, numComponents)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
numComponents INTEGER Returns the number of components.

Version

Availability: from VectorWorks 12.0