VS:GetNumberOfComponents: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(Shorten OBJECT, reserved word)
 
(One intermediate revision by one other user not shown)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetNumberOfComponents(object:HANDLE; VAR numComponents:INTEGER) : BOOLEAN;
FUNCTION GetNumberOfComponents(obj:HANDLE; VAR numComponents:INTEGER) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetNumberOfComponents(object):
def vs.GetNumberOfComponents(obj):
     return (BOOLEAN, numComponents)
     return (BOOLEAN, numComponents)
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
Line 46: Line 46:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Latest revision as of 19:54, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the number of components in an object.

FUNCTION GetNumberOfComponents(
obj :HANDLE;
VAR numComponents :INTEGER) : BOOLEAN;
def vs.GetNumberOfComponents(obj):
    return (BOOLEAN, numComponents)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
numComponents INTEGER Returns the number of components.

Version

Availability: from VectorWorks 12.0