VS:GetNumTexLayers

From Vectorworks Developer
Revision as of 13:43, 29 December 2017 by CBM-c- (talk | contribs) (expand info)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns number of texture layers (base + decals) for the specified part.

FUNCTION GetNumTexLayers(
obj :HANDLE;
texPartID :LONGINT) : LONGINT;
def vs.GetNumTexLayers(obj, texPartID):
    return LONGINT

Parameters

obj HANDLE
texPartID LONGINT

Remarks

(Orso, 2017 Dec. 29) "texPartID" flags as of VW 2017:

texPartID flags, check the VS:Function_Reference_Appendix: Texture Part ID:

3: overall for any kind of object
4:
5:
6:
7: left in walls
8: right in walls
9: start cap in walls
10: end cap in walls
11: top in walls
12: bottom in walls
13: holes in walls
14: top in roof faces/slabs
15: bottom in roof faces/slabs
16: sides in roof faces/slabs
17: top in roofs
18: bottom in roofs
19: sides in roofs
20: fascia in roofs
21: attic in roofs
22: soffit in roofs
23:
24: something unknown in roofs
25: something unknown in roofs
  • An extrude will only respond to texPartID 3
  • A roof face or a slab responds to texPartID 3 and 14-16
  • A roof or a slab responds to texPartID 3, 17-22, whereby I don't know what 24 and 25 are for roofs.
  • A wall can respond to texPartID 3 up to 15, whereby I don't know what 14 and 15 are for walls.

Version

Availability: from Vectorworks 2010