VS:GetNumTexLayers: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(expand info)
(expand with SDK)
Line 37: Line 37:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2017 Dec. 29) "texPartID" flags as of VW 2017:
([[User:Orso.b.schmid|Orso]], 2017 Dec. 29) For the texPartID flags, check the [[VS:Function_Reference_Appendix#Tex]]: ''Texture Part ID'' or more completely the SDK file RenderOptionsValues.h:
 
texPartID flags, check the [[VS:Function_Reference_Appendix]]: ''Texture Part ID'':
: 3: overall for any kind of object
: 3: overall for any kind of object
: 4: top in extrudes/sweeps
: 4: top in extrudes/sweeps
Line 57: Line 55:
: 18: bottom in roofs  
: 18: bottom in roofs  
: 19: sides in roofs
: 19: sides in roofs
: 20: fascia in roofs
: 20: gable in roofs
: 21: attic in roofs
: 21: fascia in roofs
: 22: soffit in roofs
: 22: attic in roofs
: 23:  
: 23: soffit in roofs
: 24: something unknown in roofs
: 24: dutch walls in roofs
: 25: something unknown in roofs
: 25: dormer walls in roofs
 
: 26: frame cap in curtain walls
* An extrude will only respond to texPartID 3
: 27: panel face in curtain walls
* A roof face or a slab responds to texPartID 3 and 14-16
* A roof responds to texPartID 3, 17-22, 24-25, whereby I don't know what 24 and 25 are for roofs.
* A wall can respond to texPartID 3 up to 15, whereby I don't know what 14 and 15 are for walls.


</remark>
</remark>

Revision as of 13:22, 30 December 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns number of texture layers (base + decals) for the specified part.

FUNCTION GetNumTexLayers(
obj :HANDLE;
texPartID :LONGINT) : LONGINT;
def vs.GetNumTexLayers(obj, texPartID):
    return LONGINT

Parameters

obj HANDLE
texPartID LONGINT

Remarks

(Orso, 2017 Dec. 29) For the texPartID flags, check the VS:Function_Reference_Appendix#Tex: Texture Part ID or more completely the SDK file RenderOptionsValues.h:

3: overall for any kind of object
4: top in extrudes/sweeps
5: bottom in extrudes/sweeps
6: sides in extrudes/sweeps
7: left in walls
8: right in walls
9: start cap in walls
10: end cap in walls
11: top in walls
12: bottom in walls
13: holes in walls
14: top in roof faces/slabs
15: bottom in roof faces/slabs
16: sides in roof faces/slabs
17: top in roofs
18: bottom in roofs
19: sides in roofs
20: gable in roofs
21: fascia in roofs
22: attic in roofs
23: soffit in roofs
24: dutch walls in roofs
25: dormer walls in roofs
26: frame cap in curtain walls
27: panel face in curtain walls

Version

Availability: from Vectorworks 2010