VS:GetNumTexLayers: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(add flags for partID)
Line 36: Line 36:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2017 Dec. 29) "texPartID" flags as of VW 2017:
: 3: overall for any kind of object
: 4:
: 5:
: 6:
: 7: left
: 8: right
: 9: start cap
: 10: end cap
: 11: top
: 12: bottom
: 13: holes
: 14: top in roofs/slabs
: 15: bottom in roofs/slabs
: 16: sides in roofs/slabs
 
* An extrude will only respond to texPartID 3
* A roof or a slab responds to texPartID 3 and 14-16
* A wall can respond to texPartID 3 up to 15, whereby I don't know what 14 and 15 are for walls.
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 11:08, 29 December 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns number of texture layers (base + decals) for the specified part.

FUNCTION GetNumTexLayers(
obj :HANDLE;
texPartID :LONGINT) : LONGINT;
def vs.GetNumTexLayers(obj, texPartID):
    return LONGINT

Parameters

obj HANDLE
texPartID LONGINT

Remarks

(Orso, 2017 Dec. 29) "texPartID" flags as of VW 2017:

3: overall for any kind of object
4:
5:
6:
7: left
8: right
9: start cap
10: end cap
11: top
12: bottom
13: holes
14: top in roofs/slabs
15: bottom in roofs/slabs
16: sides in roofs/slabs
  • An extrude will only respond to texPartID 3
  • A roof or a slab responds to texPartID 3 and 14-16
  • A wall can respond to texPartID 3 up to 15, whereby I don't know what 14 and 15 are for walls.

Version

Availability: from Vectorworks 2010