VS:GetNumImagePopupItems: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:32, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the number of items in the image popup.

FUNCTION GetNumImagePopupItems(
dialogID :LONGINT;
componentID :LONGINT) : INTEGER;
def vs.GetNumImagePopupItems(dialogID, componentID):
    return INTEGER

Parameters

dialogID LONGINT Index to the dialog layout that contains the image popup component.
componentID LONGINT Index to a specific image popup component.

Return Value

Returns the number of items in the specified image popup.

Example

VectorScript

numImagePopupItems := GetNumImagePopupItems(dialogID, componentID);

Python

numImagePopupItems = vs.GetNumImagePopupItems(dialogID, componentID)

Version

Availability: from VectorWorks10.0

See Also

VS Functions:

VS:InsertImagePopupObjectItem | VS:GetImagePopupObject | VS:GetImagePopupObjectItemIndex | VS:SetImagePopupSelectedItem | VS:GetImagePopupSelectedItem | VS:RemoveImagePopupItem | VS:RemoveAllImagePopupItems

VS Functions:

[[VS:InsertImagePopupObjectItem]] | [[VS:GetImagePopupObject]] | [[VS:GetImagePopupObjectItemIndex]] | [[VS:SetImagePopupSelectedItem]] | [[VS:GetImagePopupSelectedItem]] | [[VS:RemoveImagePopupItem]]

| [[VS:RemoveAllImagePopupItems]]