VS:GetNumHoles

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the number of openings in the referenced polyline.

FUNCTION GetNumHoles(
inPolyline :HANDLE;
VAR outNumHoles :INTEGER) : BOOLEAN;
def vs.GetNumHoles(inPolyline):
    return (BOOLEAN, outNumHoles)

Parameters

inPolyline HANDLE Handle to polyline.
outNumHoles INTEGER The number of openings in the polyline object.

Return Value

Returns TRUE if the polyline contains openings, otherwise returns FALSE.

Remarks

This routine never fails returning false, unregarded the object type of the handle "inPolyline" that you pass to it, or whether the polyline has holes or not.

It will only fail on "inPolyine" = NIL.

Version

Availability: from VectorWorks9.0

See Also

VS Functions:

VS:GetHole

VS Functions: [[VS:GetHole]]