VS:GetNumHoles

From Vectorworks Developer
Revision as of 22:15, 28 May 2008 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the number of openings in the referenced polyline.

FUNCTION GetNumHoles(
inPolyline :HANDLE;
VAR outNumHoles :INTEGER) : BOOLEAN;
def vs.GetNumHoles(inPolyline):
    return (BOOLEAN, outNumHoles)

Parameters

inPolyline HANDLE Handle to polyline.
outNumHoles INTEGER The number of openings in the polyline object.

Return Value

Returns TRUE if the polyline contains openings, otherwise returns FALSE.

Remarks

This routine never fails returning false, unregarded the object type of the handle "inPolyline" that you pass to it, or whether the polyline has holes or not.

It will only fail on "inPolyine" = NIL.

Version

Availability: from VectorWorks9.0

See Also

VS Functions:

VS:GetHole

VS Functions: [[VS:GetHole]]