VS:GetNumHoles: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 33: Line 33:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>
Returns TRUE if the polyline contains openings, otherwise returns FALSE.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
 
This function never returns FALSE regardless of the object type of "inPolyline" or whether "inPolyline" has holes.
 
It will only return FALSE on "inPolyine" = NIL.
 
</remark>
This routine never fails returning false, unregarded the object type of the handle "inPolyline" that you pass to it, or whether the polyline has holes or not.
It will only fail on "inPolyine" = NIL.</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 16:47, 2 February 2023

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the number of openings in the referenced polyline.

FUNCTION GetNumHoles(
inPolyline :HANDLE;
VAR outNumHoles :INTEGER) : BOOLEAN;
def vs.GetNumHoles(inPolyline):
    return (BOOLEAN, outNumHoles)

Parameters

inPolyline HANDLE Handle to polyline.
outNumHoles INTEGER The number of openings in the polyline object.

Remarks

This function never returns FALSE regardless of the object type of "inPolyline" or whether "inPolyline" has holes.

It will only return FALSE on "inPolyine" = NIL.

Version

Availability: from VectorWorks9.0

See Also

VS Functions:

VS:GetHole

VS Functions: [[VS:GetHole]]