VS:GetNumGradientSliderSegments

From Vectorworks Developer
Revision as of 21:51, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the number of segments in the gradient slider.

Note: a gradient slider must always have at least 2 segments.

FUNCTION GetNumGradientSliderSegments(
dialogID :LONGINT;
componentID :LONGINT) : INTEGER;
def vs.GetNumGradientSliderSegments(dialogID, componentID):
    return INTEGER

Parameters

dialogID LONGINT Index to the dialog layout that contains the gradient slider component.
componentID LONGINT Index to a specific gradient slider component.

Return Value

Retuns number of segments in gradient slider.

(a segment consists of a color marker and the associated midpoint marker immediately to the right)

Example

VectorScript

numSegments := GetNumGradientSliderSegments(dialogID, componentID);

Python

numSegments = vs.GetNumGradientSliderSegments(dialogID, componentID)

Version

Availability: from VectorWorks10.0