VS:GetNumGradientSliderSegments: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:32, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the number of segments in the gradient slider.

Note: a gradient slider must always have at least 2 segments.

FUNCTION GetNumGradientSliderSegments(
dialogID :LONGINT;
componentID :LONGINT) : INTEGER;
def vs.GetNumGradientSliderSegments(dialogID, componentID):
    return INTEGER

Parameters

dialogID LONGINT Index to the dialog layout that contains the gradient slider component.
componentID LONGINT Index to a specific gradient slider component.

Return Value

Retuns number of segments in gradient slider.

(a segment consists of a color marker and the associated midpoint marker immediately to the right)

Example

VectorScript

numSegments := GetNumGradientSliderSegments(dialogID, componentID);

Python

numSegments = vs.GetNumGradientSliderSegments(dialogID, componentID)

Version

Availability: from VectorWorks10.0