VS:GetNumDashDataPairsN

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetNumDashDataPairsN returns the number of dash/gap value pairs defined for the specified dash style. The "scale with thickness" setting is also returned. Dash styles support up to 5 dash/gap value pairs.

FUNCTION GetNumDashDataPairsN(
dashIndex :LONGINT;
VAR swt :BOOLEAN) : INTEGER;
def vs.GetNumDashDataPairsN(dashIndex):
    return (INTEGER, swt)

Parameters

dashIndex LONGINT The negative value of the dash pattern's internal index.
swt BOOLEAN The "scale with thickness" setting.

Example

PROCEDURE Example;
VAR
n, numPairs : INTEGER;
dashIndex : LONGINT;
scaleWThick  :BOOLEAN;
arrayDashDat : ARRAY[1..5] OF POINT;
x,y : REAL;

BEGIN

dashIndex := GetDashStyleIndexN(TRUE, 2, 0.12, 0.18, 0.03, 0.07);

numPairs := GetNumDashDataPairsN(dashIndex,scaleWThick);

FOR n := 1 TO numPairs DO BEGIN
 IF (GetDashDataValPrAtN(dashIndex, n , x, y)) THEN BEGIN
   arrayDashDat[n].x := x ;
   arrayDashDat[n].y := y ;
 END; 
END;

END;
RUN(Example);

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:GetDashDataValPrAtN | VS:GetDashStyleIndexN

VS Functions:

[[VS:GetDashDataValPrAtN]]

| [[VS:GetDashStyleIndexN]]