VS:GetNetAdapterInfo

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Return information about the network adapter

FUNCTION GetNetAdapterInfo(
adapterIndex :INTEGER;
VAR outMacAddr :STRING) : BOOLEAN;
def vs.GetNetAdapterInfo(adapterIndex):
    return (BOOLEAN, outMacAddr)

Parameters

adapterIndex INTEGER
outMacAddr STRING

Remarks

from Vlado originally: index '1' is for your first network card. '2' would be your next

one, if you have more than one. The function should return FALSE when the card with this index doesn't exist, so you can handle cases with many cards."

Version

Availability: from Vectorworks 2014